出现这样的问题,是因为他服务器采用的宝塔面板,他肯定是在后台购买过安全防护插件安装导致的。

老蒋也有问这位同学为什么要安装,他告知是感觉可能是安全,怕网站被黑。只要安装插件之后才会有上面的提示的。同样的,他还有购买过一个付费的WP压缩图片插件,也有报错:
> Warning: file_put_contents(/www/wwwroot/..../wp-content/uploads/ShortpixelBackups/index.html): failed to open stream: Permission denied...... Edit By itbulu.com
同样应该应该是这个问题,我直接把他的Nginx防火墙插件卸载,以及其他几个安全插件停止之后就可以,页面中的报错取消。